كيفية تثبيت nodeJS في توزيعة Linux Mint غير مدعومة

بصفتك مطور جافا سكريبت في العصر الحديث ، عند إعداد بيئة التطوير الخاصة بك لأول مرة على تثبيت نظام تشغيل Linux mint الجديد ، فإن أول عنصر معتاد يتم عبوره في خط سيرك هو تثبيت NodeJS وهو تطبيق جافا سكريبت لمحرك تشغيل خادم.

يعد استخدام nodesource هو الطريقة الموصى بها للحصول على أحدث إصدار رسمي أو إصدار LTS. لسوء الحظ ، قد يؤدي اتباع خطوات أمر التثبيت العادي إلى ظهور هذا الخطأ

التوزيع الخاص بك ، الذي تم تحديده باسم "tina" ، غير مدعوم حاليًا ، يرجى الاتصال بـ NodeSource على https://github.com/nodesource/distributions/issues إذا كنت تعتقد أن هذا غير صحيح أو ترغب في أن يتم النظر في توزيعك للدعم

يرجع هذا الخطأ إلى أن ملف إعداد nodesource يحتوي على قائمة بتوزيعات Linux المدعومة التي تم اختبارها لدعمها ، ومن المحتمل أن نسخة توزيع Linux التي تستخدمها هي أحد أحدث الإصدارات التي لم يتم دعمها من قبل nodesource.

خطوات التثبيت التالية تحتوي على إصلاح لمساعدتك على تثبيت NodeJS بنجاح. ملحوظة

  • هذا المثال خاص بتوزيع Linux Mint tina (19.2) ، واستبدل المعلمات عند الحاجة.
  • يمكن أن يكون setup_12.x أيضًا setup_10.x وفقًا لإصدار الإصدار المفضل لديك
sudo apt-get install python-software-properties

قم بتنزيل برنامج الإعداد النصي باستخدام wget

wget https://deb.nodesource.com/setup_12.x

افتح برنامج الإعداد النصي باستخدام

sudo nano setup_12.x

قم بالتمرير في منتصف الطريق إلى أسفل برنامج الإعداد النصي حيث يتم سرد قائمة توزيعات لينكس المدعومة ، أضف هذا السطر بعد تعريفات تجميع Linux mint check_alt "Linux Mint" "tina" "Ubuntu" "bionic"

احفظ البرنامج النصي للإعداد واجعله قابلاً للتنفيذ

sudo chmod + x setup_12.x

أخيرًا ، قم بتشغيل التثبيت

sudo apt-get install -y nodejs

نشر في الأصل على https://blog.ugokoli.com في 18 يناير 2020.